Instalar y configurar Eclipse para programar en Python

Bueno siguiendo con la lista de temas para posinstalacion pensaba seguir con algo del tipo instalar driver de nvidia u algo por el estilo, pero hace poco en uno de eso pocos momentos en los cuales me puedo dedicar al ocio y cultura en la red, revise el foro de camayihi, el lug al cual pertenesco y veo en tema del foro que un amigo y compañeroa tenido problemas para trabajar en eclipse con el plugin de python, por lo tanto adelanto este post, el cual problablemente hubiera demorado un par de semanas mas en salir a la luz.

bueno para empesar debemos aclarar algunas cosas. eclipse es un gran IDE para desarrollo con un solo inconveniente de momento, consume algo de recursos asi que algunos equipos posiblemente no puedan funcionar optimamante con el; este es el caso para equipos con menos de 512 Mb de RAM.

para programar ne python podemos hacer uso de muchos otros IDEs de gran calidad y algo mas livianos; entre los cuales puedo destacar: Open Komodo, Geany y Pyragua. claro que si eres alguien sin complicaciones tambien puedes abrir Gedit el editor de texto por defecto de Gnome, crear un archivo nuevo; guardarlo con extencion .py y automaticamente tendras resaltador de sintaxis y podras empezar a programar de inmediato (no aconsejable para grandes y medianos proyectos).

volviendo al tema para poder instalar eclipse deveras tener instaladas tanto Java Development Kit (JDK) para poder compilar en java, como tambien Java Runtime Environment (JRE) para poder ejecutar las aplicaciones compiladas.(esto es un requisito para eclipse, pues originalmente es un IDE para java). por lo tanto nos instalamos la ultima version, de momento en la rama testing de debian es la version 6, para instalarla con aptitude, apt o sinaptyc en este caso con aptitude:

aptitude install sun-java6-jre sun-java6-jdk

Posterior a esto estaremos listos para instalar eclipse y PyDev el plugin requerido para trabajar con python:

aptitude install eclipse pydev

Ahora si estamos listos para iniciar eclipse, despues de iniciarlo este nos pedira un directorio de trabajo, algo de rutina y nos dejara acceder al IDE; si de inmediato intentamos crear un nuevo proyecto pydev, el IDE no lo permitira pues aun falta configurar interprete python de eclipse para que trabaje con python y pydev. para hacer esto nos dirigiremos a Ventana/Preferencias en la pestaña Pydev/Interprete Python, damos click a el boton “Nuevo” y navegamos hasta la ruta donde tenemos instalado python; por lo general en /usr/bin/python despues cargara automaticamente algunos ajustes requeridos. damos ok y estaras listo para programar en python.

Anuncios

3 comments so far

  1. Jorge Galvis on

    Muchas Gracias brother… como te dije me interesa tus repos a ver sì por ahi esta la solucion…

  2. ruffini on

    no puedo descargar el eclipse… algun otro link? cual es el ultimo y cual me recomendas?
    saludos y gracias

  3. Diego Saavedra on

    me gustaria saber si hay como cambiar el idioma a español soy de Ecuador-Loja y me gustaria lo siguiente:

    Cambiar el idioma a español
    Instalar plugin para php
    instalar plugin para python

    gracias por la colaboración de antemano


Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s

A %d blogueros les gusta esto: